Author Topic: neewbie-a small problem  (Read 2497 times)

kissyy

  • Regular Member
  • *
  • Posts: 8
neewbie-a small problem
« on: April 29, 2016, 11:37:44 PM »
 :biggrin:I just downloaded the EC and start with an example froum “EasyCode\Examples\Masm\x86\CpuID”
but something wrong :(
I dont know why
----------------------
Compiling resources...
CpuIDRes.rc (29): error RC2133 : unexpected value in value data


CpuIDRes.rc (29): error RC2132 : expected VALUE, BLOCK, or END keyword
----------------------
i also tested other examples,and a new empty project,still the same problem.
And another problem is :icon_eek:
I delete some lines in the example CpuID and saved the file.
then i closed the project and reopen the CpuID  and found the code still not change :dazzled:

thank you for you patience

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #1 on: April 30, 2016, 04:15:20 AM »
Hi kissyy,

Thanks for using Easy Code and sorry for the inconveniences.

After loading the CpuID project, go to the Project-->Properties menu and click the Tools section (in the left part of the window). Then make sure you have the right path for the compiler, linker and resource compiler, as shown in the attached image (as you will see in it, I have all those tools in drive G:). When all the paths are correct, the project should be built without errors.

Regards,

Ramon
EC coder

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #2 on: April 30, 2016, 03:02:22 PM »
Hi kissyy,

Thanks for using Easy Code and sorry for the inconveniences.

After loading the CpuID project, go to the Project-->Properties menu and click the Tools section (in the left part of the window). Then make sure you have the right path for the compiler, linker and resource compiler, as shown in the attached image (as you will see in it, I have all those tools in drive G:). When all the paths are correct, the project should be built without errors.

Regards,

Ramon
Dear Ramon,thank you for your answer,but it did not work.
The path is all right,I have all those tools in drive E,I checked on my Win10 x64 system and win xp x86 system on Vmware,the problem still exists.

Best Regards.

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #3 on: April 30, 2016, 03:08:15 PM »
BTW. Complie CpuID is all right,no errors.
When I tried Compile Resources or Build CpuID.exe the problem shown.
Thank you again.
The pic on the attachment.

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #4 on: April 30, 2016, 10:12:10 PM »
Hi kissyy,

Please give me some time to study the attached files and I will come back to you.

Ramon
EC coder

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #5 on: April 30, 2016, 10:39:00 PM »
Hi again kissyy,

Please let me know the following information:

1. In which drive is the EasyCode folder?
2. Are you using the 32 or the 64-bit version of EasyCode?
3. Are you using the las version of MASM SDK?
4. Are you building the CpuID project from its original location (\EasyCode\Examples\Masm\x86\CpuID)?
5. Are you logged in as an administrator?
6. May I see all your Settings tabs?
7. Can you build any other example project?

Thanks in advance!

Ramon
EC coder

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #6 on: April 30, 2016, 11:27:38 PM »
I relied twice but did not shown on the web :dazzled:
also an attachment 8.25MB,so this time i just post the letters :(
..............
Hi,rsala
thank you for your patience.
This time I delete EC folder and start with a new one,some operation I record with video on the attachment.
I do the test on my win10 x64 system.
This time i test all the examples in the folder "EasyCode\Examples\Masm\x86",found some examples woring well,but some did not.
the following seems all performed good:ECPlayer
Threads
Drives
TabStrip
RSEditor
MIDIplay
MDI
ECService--ECService.ecp
The following did not:
NOT OK :
CpuID
ECClock
ECPDriver
ECService--ECServiceCtrl.ecp
ECPDrvTest
-------------
For your Q:
1.EasyCode is on drive D, masm32 on drive E,system is on C
2.I tested 32bit and 64 bit version EC, seems nothing different.
3.m32v11w10.zip the newest version of masm32 i think
4.yes,all examples rom its original location
5.yes
6.you can find it on the vedio
7.i test all example
btw.this time i build new blank projects both 32bit and 64bit EC version,all works well. :lol:

now my problem is why some examples does not work well.
thank you again my friend! :t

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #7 on: April 30, 2016, 11:30:20 PM »
i konw the problem:
...............................
Restrictions: 4 per post, maximum total size 512KB, maximum individual size 512KB
..............................
Can i have your email my friend ?so i can email the vedio :lol:

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #8 on: May 01, 2016, 06:11:48 PM »
Hi kissyy,

I sent you a private message!

Regards  :t
EC coder

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #9 on: May 02, 2016, 05:03:26 AM »
Hi,

kissyy and I have been dealing with the resource compilation problem and I finally could guess the reason. Those projects that fired a resource compiler error were due to the "CopyRight" value, that is "Héctor A. Medina", in the Version resource. It seems that the accent mark "é" (in Héctor) does not work fine on Chinese Windows.

I am really grateful for all kissyy's help!
EC coder

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #10 on: May 04, 2016, 02:51:12 PM »
I should thank you for your great patience, and you really did a good job. :t :greenclp:

AssemblyChallenge

  • Member
  • **
  • Posts: 93
Re: neewbie-a small problem
« Reply #11 on: May 05, 2016, 12:23:04 AM »
Great. But the problem is then Windows or EC2 related?  :icon_eek:

kissyy

  • Regular Member
  • *
  • Posts: 8
Re: neewbie-a small problem
« Reply #12 on: May 05, 2016, 09:17:23 PM »
It seems to a problem of rc.exe . :icon_eek:

jj2007

  • Member
  • *****
  • Posts: 7643
  • Assembler is fun ;-)
    • MasmBasic
Re: neewbie-a small problem
« Reply #13 on: May 05, 2016, 11:21:37 PM »
Try saving the rc file as Unicode.

rsala

  • Moderator
  • Member
  • *****
  • Posts: 242
    • Easy Code
Re: neewbie-a small problem
« Reply #14 on: May 06, 2016, 04:12:44 AM »
Hi All,

Everything seems to work fine on western languages and I do not have the chance to make tests on a Chinese Windows, so kissyy is helping me a lot to find the problem (I guess the WideCharToMultiByte function does not work in the same way on Chinese Windows).

Kissyy: I think you already tried to compile the resource file as Unicode text, but if not, just uncheck the Always generate resource files in ANSI mode option (in the Project-->Properties), compile the resources and please let us know the results. Thanks.

EC coder