The MASM Forum

Projects => Easy Code IDE 32/64-bit => Topic started by: satpro on January 22, 2014, 09:35:31 PM

Title: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 22, 2014, 09:35:31 PM
Hi,

I just installed Easy Code / GoAsm and am trying to add an include file to the project using the project explorer (or from the menu), but am getting a small dialog with no text and an unmarked button on it.  After that I cannot close the dialog unless I press alt + F4, at which time a new dialog (with an OK button) opens saying "Error reading language file. Default language will be set."  That dialog cannot be closed with any method.  I then go into Task Manager to end the process.  What am I not doing correctly?

The sample files seem to be compiling okay (no errors).  I am able to include files in the source script.
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 23, 2014, 07:05:21 AM
Hi satpro,

Thanks for using Easy Code and sorry for the inconveniences.

Are you using the latest version (1.06.0.0025)? If so, I don't know what can be happening since it works fine to me. Please close the IDE if running, edit the EasyCode.ini file using a text editor like Notepad, search for "Language" keyword and set it to none (Language=). Then save the ini file, run Easy Code again and see if the problem is solved.

Regards,

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 23, 2014, 08:09:16 AM
Hi again and thank you for the quick reply,

I tried what you suggested a couple of different ways:

1. Setting-> Language=
2. Setting-> Language=0
3/4. Both ways above in normal / administrator mode

The same thing is happening.  Easy Code must be closed through Task Manager and the .ini file reverts to Language=<Default>.

I am using the Jan 4, 2014 update (1.06.0.0024) and a fresh download of all the GoAsm tools.  It seems to compile okay if I add the include files to the source script.  Adding through Menu/Project Explorer is when the trouble occurs.

Edit: I am going to re-install into the drive root and give that a shot.  Right now it is installed on Google Drive.  I'll just put the project files on Google Drive instead & report back.
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 23, 2014, 03:55:27 PM
Well, I re-installed Easy Code (fresh zips of EasyCode, ECGo, and Headers) into the C: drive while reading step by step from a printed-out copy of the instructions.  The same thing is happening, and this is on another Windows 7 computer connected to my LAN.  I had originally planned to install this to Google Drive as it is an easy way for me to move from room to room to write code that is auto-backed.

After going into the relevant folders on the second computer it seems everything is where it should be, the sample programs compile and run correctly, and I am able to add include files with no problem as long as they are added into the assembly source code.  Doing it from within Easy Code brings up a faceless dialog, and if alt+F4 is pressed, another dialog saying the language file could not be read, and closeable only with Task Manager -- the same as before.  I even tried it using Spanish as the default language, again without success.

You mentioned version (1.06.0.0025).  I am using 1.06.0.0024, but it is the only version I was able to download.  Is there a newer version somewhere?
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 24, 2014, 05:54:53 AM
Hi satpro,

I am really sorry for all those problems and I do not know why that happens. In my Windows 7, both 32 and 64-bit, Easy Code works fine. About the version 1.06.0.0025, it does not exist. Please forgive my error.

I will test version 1.06.0.0024 to see if I can see any problem and I'll come back to you.

Regards,

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 24, 2014, 07:02:10 AM
I'm terribly sorry but everithing works fine in Windows 7 (32 and 64-bit), Windows Vista and Windows XP, so I have no idea what is happening in your machine. Althoug it should have no effect, what language do you use? What language is your Windows O.S.? Are all language files in the 'Language' folder?

Thanks!
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: K_F on January 24, 2014, 07:21:55 AM
Satpro:
Have you limited which Win7 services can run on your PC.
IOW have you disabled a lot of Win7 services.

I do this to have a minimum system running, and found it interfering with Easycode compilation, so had to re-enable some services.
It's not an Easycode problem but Win7s service dependencies - Annoying, but this is what Bill's cronies have done...
:)
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 24, 2014, 08:01:22 AM
Hi K_F,

May I know which services interfere with Easy Code? Thanks!

Regards!

Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: dedndave on January 24, 2014, 11:04:16 AM
Ramon,
it doesn't sound like the services interfere with EasyCode
it sounds like they need to be running, but have been stopped to reduce CPU load

that brings up an interesting point...
that such services should be identified and running when testing code
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 24, 2014, 12:32:41 PM
Hi again rsala,

I am using Windows 7 on the two I program on, English (US) on both.  I have a fairly involved system, and don't have any other software issues with anything that I can think of, but it is happening on two computers.  In response to K_F's comment I went into services and found only a few that were actually disabled -- and set those to manual, then tried it again.  No luck.  I'll keep trying at this...

 
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 24, 2014, 05:03:39 PM
Thanks dendave!
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 24, 2014, 05:06:38 PM
Hi satpro,

I really don't know what to say! Nobody has never complained about something like this. Do you know whether Easy Code Masm behaves in the same way?
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 24, 2014, 06:29:45 PM
Hi rsala,

Haven't tried the MASM version but I did download it and will give it a try--bet it works.  This has me bugged now because EasyCode/GoAsm works just fine if I include files the old-fashioned way. It's definitely not a directory, AV, or permissions issue.

Thanks at least for taking the time to help me with this.

Bert

P.S.  Do you have an older GoAsm version archived that I could get my hands on to try?
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 25, 2014, 06:06:28 AM
Hi satpro,

Here are the links for versions 1.06.0.0020, 1.06.0.0021, 1.06.0.0022 and 1.06.0.0023:

http://easycode.cat/English/Download/EasyCodeGoAsm1060020Eng.zip
http://easycode.cat/English/Download/EasyCodeGoAsm1060021Eng.zip
http://easycode.cat/English/Download/EasyCodeGoAsm1060022Eng.zip
http://easycode.cat/English/Download/EasyCodeGoAsm1060023Eng.zip

Please let me know if any of them works.

Regards,

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 26, 2014, 10:32:56 AM
Version 1.06.0.0020 did the same thing with a fresh install in another drive.  It says it's having trouble reading the Language file, same as the later version.
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 27, 2014, 06:50:27 AM
Hi,

I'm getting crazy with this. I'm terribly sorry but I can't see where the problem is so I can't fix it. Everything works fine in all computers and Windows platforms where I have tested Easy Code GoAsm.

I will keep on trying.

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 27, 2014, 07:22:16 AM
Hi,

I'm getting crazy with this. I'm terribly sorry but I can't see where the problem is so I can't fix it. Everything works fine in all computers and Windows platforms where I have tested Easy Code GoAsm.

I will keep on trying.

Ramon

Hi Ramon,
You know what?  Don't sweat it.  No sense getting crazy over something one person (me) is talking about.  It must be something on my end.  Just wish I knew what.  I'll code the long way and just add the headers in code -- I am used to doing that anyhow.  The IDE is nice to work with, and it's really all I was after anyway, so that's good enough.  In the meantime, if I do manage to figure out what it is I'll be sure to report back.

Thanks for all your help,
Bert
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: anta40 on January 27, 2014, 11:36:04 PM
Hi,

I'm getting crazy with this. I'm terribly sorry but I can't see where the problem is so I can't fix it. Everything works fine in all computers and Windows platforms where I have tested Easy Code GoAsm.

I will keep on trying.

Ramon

Hi Ramon,

Does EasyCode have a mechanism to generate error dump?
I know that not being able to reproduce bug can be very confusing, and in this case
examining error dump can provide some hints about the bug itself.
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 28, 2014, 06:37:09 AM
Hi satpro,

Thanks a lot for you kind words. I'll try to find out the problem.

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 28, 2014, 06:41:21 AM
Hi anta40,

Thanks for giving ideas.

No, unfortunately Easy Code does not have any mechanism to generate error dump.

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: jj2007 on January 28, 2014, 07:28:32 AM
No, unfortunately Easy Code does not have any mechanism to generate error dump.

A simple debug macro could do the job, applied near the code area where the problem seems to be.
This one uses a switch; if usedeb=0, no extra code will be generated. With usedeb=1, extra checks are being performed, and a console window will be created to display the error line:
Code: [Select]
include \masm32\include\masm32rt.inc

usedeb=1 ; 0=no checks, 1=check
voidNonZero MACRO args
LOCAL tmp$
  @CatStr(<;>, <args>)
  if usedeb
.if !eax
pushad
invoke GetConsoleWindow
.if !eax ; must be SUBSYSTEM:WINDOWS...
invoke AllocConsole
.endif
tmp$ CATSTR <chr$("## eax is zero in line >, %@Line, < ##")>
print tmp$, 13, 10
popad
.endif
  endif
ENDM
.data
rc RECT <>
hWin dd ?
.code
start:
voidNonZero rv(GetConsoleWindow) ; uses Masm32 rv macro
invoke GetClientRect, edx, addr rc
voidNonZero eax ; more traditional
voidNonZero rv(GetClientRect, eax, addr rc)
MsgBox 0, str$(rc.right), "Pixels wide:", MB_OK
exit
end start
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 28, 2014, 08:15:11 AM
Hi jj2007,

Thank you very much!

I will test the macro.

Ramon
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: satpro on January 30, 2014, 08:15:03 AM
I would like to announce that Ramon has taken the steps to fix my problem with adding include files through Project Explorer/Menu.  He did it in a professional, unrelenting manner (through personal messaging) that has left me impressed to the point of bewilderment.

Just thought everyone should know.

Thanks Ramon.  You're a class act for sure.
Title: Re: Having trouble adding files from Menu or Project Explorer
Post by: rsala on January 30, 2014, 10:07:43 AM
satpro: Thank you very much for your help!

Thanks to satpro I have been able to fix the problem, although it has no sense and it seems not to happen in any other computer (that's the most mysterious) .

I expect to release a new version in a few days.

Thanks to everybody,

Ramon