The MASM Forum

Projects => Rarely Used Projects => RadAsm IDE Support => Topic started by: Raistlin on June 25, 2015, 11:23:24 PM

Title: RADASM intellisense STRUCT issues
Post by: Raistlin on June 25, 2015, 11:23:24 PM
Hi KetilO, Donkey and the others that have improved RADASM so much over the years,
my deepest thanks for your efforts.

I have a small issue with STRUCTS using MASM under RADASM 3.0.0.9c

The intellisense does'nt seem to show up all the component fields for quickselect.

example:
Code: [Select]
OSVERSIONINFOEX STRUCT
  dwOSVersionInfoSize DWORD ?
  dwMajorVersion  DWORD ?
  dwMinorVersion  DWORD ?
  dwBuildNumber   DWORD ?
  dwPlatformId    DWORD ?
  szCSDVersion    BYTE  128  dup (?)
  wServicePackMajor WORD ?
  wServicePackMinor WORD ?
  wSuiteMask        WORD ?
  wProductType      BYTE ?
  wReserved         BYTE ?
OSVERSIONINFOEX ENDS

RADASM will not display the members wSuiteMask & wProductType - but will end the selection list with wReserved.

Programmatically I can obviously override as such (below) and it works - just thought there might be a workaround.

Code: [Select]
ASSUME esi : ptr OSVERSIONINFOEX
...
mov al, [esi].wProductType
...

Thanks
Raistlin
Title: Re: RADASM intellisense STRUCT issues
Post by: qWord on June 25, 2015, 11:58:42 PM
RadAsm use the declaration found in file winasmStruct.api -> rename your structure declaration or modify the API file.
Title: Re: RADASM intellisense STRUCT issues
Post by: Raistlin on June 26, 2015, 12:10:05 AM
Thanks Qword, will have a look