Author Topic: EasyCode 2.0 first bug  (Read 2837 times)

AssemblyChallenge

  • Member
  • **
  • Posts: 110
EasyCode 2.0 first bug
« on: October 09, 2015, 07:50:53 AM »
Sorry man, maybe I'm too lucky bumping into this kind of things  :lol:

Ok, here we go. Opened and configured the new and shiny EC2, so far so good.

Created and saved a new empty masm visual project. While looking at the tools I randomly decided to add a SysLink and as soon as I clicked in the form... EC dies  :(

After several tries, it always happens. Then I tested adding every control one by one and only the SysLink makes EC2 crash.

Managed to obtain screenshot, generate crash dump and track behaviour with Procmon (although nothing clear so far from this one). Will only add the image here as the DMP file is too heavy for the forum.

Regards.

PD: I like the new interface  :icon_cool:

rsala

  • Moderator
  • Member
  • *****
  • Posts: 296
    • Easy Code
Re: EasyCode 2.0 first bug
« Reply #1 on: October 09, 2015, 08:34:21 PM »
Thank you very much for the report. I will try to find the bug and fix it this evening.
 :icon_redface:

EC coder

AssemblyChallenge

  • Member
  • **
  • Posts: 110
Re: EasyCode 2.0 first bug
« Reply #2 on: October 10, 2015, 12:28:24 AM »
Ah, don't worry  ;)

Got all the info I sent you by mail ?

rsala

  • Moderator
  • Member
  • *****
  • Posts: 296
    • Easy Code
Re: EasyCode 2.0 first bug
« Reply #3 on: October 10, 2015, 06:01:24 AM »
I am terribly sorry!

The problem is that the "SysLink" control is not yet implemented, so it should not appear in the tool box.

I will fix this and I will wait for more bugs to appear. Then I will release a new version next week.

Thanks for your help!
EC coder

K_F

  • Member
  • *****
  • Posts: 1482
  • Anybody out there?
Re: EasyCode 2.0 first bug
« Reply #4 on: October 11, 2015, 09:48:13 PM »
Hi Ramon.. still getting the crash on the numpad - this time on the '8' key.
Not a frequent as EC1 though - It seems to be a combination of keystrokes, but always catches you when you least expect it  :biggrin:

I'm not sure but I think it could be when one accidently pushes two (or more keys) at once, as my fingers are 'all over the keyboard' when typing and occasionally press a few keys to fast  - I'll keep an eye on this.
 :t
'Sire, Sire!... the peasants are Revolting !!!'
'Yes, they are.. aren't they....'

rsala

  • Moderator
  • Member
  • *****
  • Posts: 296
    • Easy Code
Re: EasyCode 2.0 first bug
« Reply #5 on: October 12, 2015, 06:52:53 AM »
Thanks K_F!
 :t
EC coder

AssemblyChallenge

  • Member
  • **
  • Posts: 110
Re: EasyCode 2.0 first bug
« Reply #6 on: October 17, 2015, 03:11:24 AM »
Great! With today's update, EC2 is -so far- working good with no crash at Syslink.

From now on all of my new projects will be made on EC2. And as usual, expect a lot of feedback from me.

 :t

PD: Should I change my avatar in order to reflect the new icon??  :lol:

rsala

  • Moderator
  • Member
  • *****
  • Posts: 296
    • Easy Code
Re: EasyCode 2.0 first bug
« Reply #7 on: October 17, 2015, 03:51:31 AM »
Great! Your feedback is always welcome (but let me rest from time to time :t).

PD: Yes, why not!  :lol:
EC coder