Author Topic: Windows 7 and Visual Studio 2008 debug register panel  (Read 3574 times)

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
Windows 7 and Visual Studio 2008 debug register panel
« on: August 09, 2012, 08:13:25 AM »
How do I get a register display in the Visual Studio 2008 debugger, it seems to be missing under Windows 7.

Dave.

Ryan

  • Guest
Re: Windows 7 and Visual Studio 2008 debug register panel
« Reply #1 on: August 09, 2012, 11:51:49 AM »
Are you looking at the disassembly?  Mine come up through the auto-watch.

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
Re: Windows 7 and Visual Studio 2008 debug register panel
« Reply #2 on: August 09, 2012, 12:15:45 PM »
Ryan,

I put an INT 3 in line and executed and Visual Studio 2008 came up, and showed the source breakpoint, but I see no way to show the register panel.

At least I can do an assembly and link now. But, I need to see the registers.

Is this because this is a 64 bit system and the executable is 32 bit?

Dave.

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
Re: Windows 7 and Visual Studio 2008 debug register panel
« Reply #3 on: August 10, 2012, 05:56:46 AM »
Are you looking at the disassembly?  Mine come up through the auto-watch.

Ryan,

I found the answer on the following forum: http://www.sevenforums.com/, you might want to check them out.

Visual Studio>Tools>Options>Debugging>General>"enable address level debugging" and "Show disassembly if source is not available".

I now have my registers and can start debugging. My problem is in a module (files.exe) that displays directory and file information. This worked in Windows XP, both for the C: drive and other drives. In Windows 7 it fails on the C: drive (even if I execute as administrator) on a directory "C:\Program Files\DVDMaker\ and gets an API error and when I tried (in the program) to display the text message, I get something like "bad pointer", I was expecting something like "unable to access". The program completes normally for other drives (F: 12,928 KB file, 77647 lines).

Dave,