Author Topic: MASM 9.0 failure and response file (.rsp) failure  (Read 218 times)

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
MASM 9.0 failure and response file (.rsp) failure
« on: September 26, 2017, 03:56:04 AM »
Somehow my post disappeared, the title reappeared when I logged off and back on again, but the message body and attachment disappeared, try again!

Long time, no see.

I encountered some strange errors while modifying working existing code. I thought it might be because of the size of the program so I decided to convert the program to a library ALA FPULIB in MASM32. That also failed with strange errors.

Please see the attached zip of a text file describing the errors.

Dave.

jj2007

  • Member
  • *****
  • Posts: 7728
  • Assembler is fun ;-)
    • MasmBasic
Re: MASM 9.0 failure and response file (.rsp) failure
« Reply #1 on: September 26, 2017, 04:39:37 AM »
.\pkg\Prog.pkg(1050) : error A2108:use of register assumed to ERROR
.\pkg\Prog.pkg(1026) : error A2107:cannot have implicit far jump or call to near label

Looks like a .code or .data is missing.

aw27

  • Member
  • ****
  • Posts: 851
  • Let's Make ASM Great Again!
Re: MASM 9.0 failure and response file (.rsp) failure
« Reply #2 on: September 26, 2017, 04:42:24 AM »
Quote
I don't even remember where I found this preamble code, I have just been using this forever
:badgrin:
Probably you should spend 5 minutes thinking about that by now, because it is a huge mess out there.

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
Re: MASM 9.0 failure and response file (.rsp) failure
« Reply #3 on: September 26, 2017, 05:16:24 AM »
Thank you JJ.

There is a large amount of code added that MASM has already processed without declaring an error until it gets into existing good code and then starts complaining. I will look into the last thing I think MASM has examined, but without any error messaged it is hard to determine what might be missing,

My real concern is why MASM fails when using a response file to build a library when the library code assembled correctly when assembled as a stand alone program.

Dave.

jj2007

  • Member
  • *****
  • Posts: 7728
  • Assembler is fun ;-)
    • MasmBasic
Re: MASM 9.0 failure and response file (.rsp) failure
« Reply #4 on: September 26, 2017, 06:32:30 AM »
Dave,
Use this macro generously throughout your code, and try to find the line that causes the trouble:
Code: [Select]
ShowSection MACRO
Local tmp$
  tmp$ CATSTR <** line >, %@Line, < is in the >, @CurSeg, < section **>
  % echo tmp$
ENDM

I am pretty sure that it is a missing section delimiter. Usage is simply ShowSection - no arguments.

KeepingRealBusy

  • Member
  • ***
  • Posts: 426
Re: MASM 9.0 failure and response file (.rsp) failure
« Reply #5 on: September 26, 2017, 08:10:51 AM »
JJ,

Thank you for the help - found it. I had deleted a procedure at the head of the code (no longer used), unfortunately, it also had the required ".code" following some procedure documentation.

Still waiting to here from someone about the .rsp problem.

Dave.