Author Topic: UAsm 2.41 bug, unknown cause.  (Read 323 times)

johnsa

  • Member
  • ****
  • Posts: 589
    • Uasm
Re: UAsm 2.41 bug, unknown cause.
« Reply #15 on: October 03, 2017, 02:13:45 AM »
Ok,

I've managed to replicate the issue with uasm32..

uasm64 produces:

Code: [Select]
D:\pointy>c:\jwasm\uasm64 /c /coff /Cp /Fl /Sn /Sg jimg.asm
UASM v2.41, Oct  2 2017, Masm-compatible assembler.
Portions Copyright (c) 1992-2002 Sybase, Inc. All Rights Reserved.
Source code is available under the Sybase Open Watcom Public License.


***********
ASCII build
***********

jimg.asm: 9 lines, 2 passes, 68 ms, 0 warnings, 0 errors

while uasm32 for me yields:

Code: [Select]
D:\pointy>c:\jwasm\uasm32 /c /coff /Cp /Fl /Sn /Sg jimg.asm
UASM v2.41, Sep 29 2017, Masm-compatible assembler.
Portions Copyright (c) 1992-2002 Sybase, Inc. All Rights Reserved.
Source code is available under the Sybase Open Watcom Public License.


***********
ASCII build
***********

D:\masm32\include\windows.inc(21253) : Error A2169: General Failure
 D:\masm32\include\windows.inc(21253): Included by
  jimg.asm(5): Main line code

Now at least I have something to trace :)

johnsa

  • Member
  • ****
  • Posts: 589
    • Uasm
Re: UAsm 2.41 bug, unknown cause.
« Reply #16 on: October 03, 2017, 02:19:50 AM »
Problem found and fixed :) It was a missing brace in a block of code added for 2.41.. ;)

Updated packages will be available soon after some more testing of all this new record fun.

johnsa

  • Member
  • ****
  • Posts: 589
    • Uasm
Re: UAsm 2.41 bug, unknown cause.
« Reply #17 on: October 04, 2017, 12:38:13 AM »
New packages are up on the site with the fix for this (dated 03-10-2017).

Cheers
John

jimg

  • Member
  • **
  • Posts: 196
Re: UAsm 2.41 bug, unknown cause.
« Reply #18 on: October 04, 2017, 04:22:23 AM »
All fixed.  Thanks :biggrin: