Author Topic: Anybody with GTK3 on LInux ?  (Read 330 times)

GoneFishing

  • Member
  • *****
  • Posts: 1052
  • Gone fishing
Anybody with GTK3 on LInux ?
« on: December 20, 2017, 09:55:29 PM »
I'm writing new GTK3 example.
I have installed GTK version 3.10.8
Should I use the latest version 3.22  instead my older one?
Which version of GTK3 do you have?
To find it out run this command in terminal:
Code: [Select]
pkg-config  --modversion gtk+-3.0

AW

  • Member
  • *****
  • Posts: 1303
  • Let's Make ASM Great Again!
Re: Anybody with GTK3 on LInux ?
« Reply #1 on: December 20, 2017, 10:08:19 PM »
I'm writing new GTK3 example.
I have installed GTK version 3.10.8
Should I use the latest version 3.22  instead my older one?
Which version of GTK3 do you have?
To find it out run this command in terminal:
Code: [Select]
pkg-config  --modversion gtk+-3.0
I have the latest because I installed yesterday.
On the other hand I can not run ubuntu now because it hangs on boot.  :shock: saying it started update UTMP. I will have to use a saved snapshot and find out how to make ubuntu happy.

GoneFishing

  • Member
  • *****
  • Posts: 1052
  • Gone fishing
Re: Anybody with GTK3 on LInux ?
« Reply #2 on: December 20, 2017, 10:15:17 PM »
I hope that you installed it in virtual machine?
I wish you to be patient  until you  get accustomed to new world
Anyway could you check GTK version when your system will be workable?

AW

  • Member
  • *****
  • Posts: 1303
  • Let's Make ASM Great Again!
Re: Anybody with GTK3 on LInux ?
« Reply #3 on: December 20, 2017, 10:26:38 PM »
Anyway could you check GTK version when your system will be workable?
Fortunately, I made a snapshot this morning.  ;)
My version is 3.18.9

Quote
I wish you to be patient  until you  get accustomed to new world
Yeap, I know how nice Linux is. I don't play much with it, I had to last week then I remembered to convert the GTK example.


GoneFishing

  • Member
  • *****
  • Posts: 1052
  • Gone fishing
Re: Anybody with GTK3 on LInux ?
« Reply #4 on: December 20, 2017, 10:32:39 PM »
Fortunately, I made a snapshot this morning.  ;)
My version is 3.18.9
...
Fine!
Your GTK version has support for OpenGl area. An interesting feature to play with !
I'll  think  about  how I may update GTK on my machine.