Author Topic: Point Problem  (Read 96 times)

shankle

  • Member
  • ****
  • Posts: 783
Point Problem
« on: July 10, 2018, 09:50:34 PM »
                   7-10-2018
Thanks for any help.
Stats: GoAsm 64-bit, Windows 7 pro 64-bit

Having a problem with the "POINT" structure.
Am I missing a header file?????

.const
POINT       STRUCT
Px        dd 0
Py        dd 0
POINT       ENDS

DATA SECTION
hdc    dq  0

WndProc:
    LOCAL  pt:POINT

invoke GetCursorPos [pt]
invoke BitBlt,[hdc],[pt:Px],[pt:Py],16,16,[hdc],10,60,SRCCOPY

Error!
Could not open an input file (PT.DLL)
Needed for forced Dll or import by ordinal
Output file not made

jj2007

  • Member
  • *****
  • Posts: 8507
  • Assembler is fun ;-)
    • MasmBasic
Re: Point Problem
« Reply #1 on: July 10, 2018, 10:03:53 PM »
Is it pt:px or pt.px?

Yuri

  • Member
  • **
  • Posts: 168
Re: Point Problem
« Reply #2 on: July 10, 2018, 10:36:33 PM »
Yes, it should be [pt.Px]. A point problem indeed.

shankle

  • Member
  • ****
  • Posts: 783
Re: Point Problem
« Reply #3 on: July 10, 2018, 11:31:03 PM »
Thanks guys.
I don't work with structures very much and have a memory problem.
Yes it should be pt.Px
All you young guys don't have this problem YET:)

wjr

  • Member
  • **
  • Posts: 191
    • WJR's website
Re: Point Problem
« Reply #4 on: July 13, 2018, 07:24:36 AM »
Also a comma missing after GetCursorPos. That one is still on my fix to-do list...

shankle

  • Member
  • ****
  • Posts: 783
Re: Point Problem
« Reply #5 on: July 13, 2018, 09:33:10 AM »
Thanks. problem fixed now.