Author Topic: Fusion libraries are working?  (Read 280 times)

HSE

  • Member
  • *****
  • Posts: 1188
  • <AMD>< 7-32>
Fusion libraries are working?
« on: November 23, 2019, 07:20:20 AM »
Hi Biterider!

At linking time I have for every library I maked this king of messages :
Code: [Select]
LinkedList.lib(LinkedList.obj) : error LNK2005: _TPL_OA_Primer already defined in integ01.obj
LinkedList.lib(LinkedList.obj) : error LNK2005: _TPL_OA_Primer_DMT already defined in integ01.obj
LinkedList.lib(LinkedList.obj) : error LNK2005: _TPL_OA_DesLUT already defined in integ01.obj

An other thing here:
Code: [Select]
ButtonW.lib(ButtonW.obj) : error LNK2005: _TPL_OA_BUTTONW already defined in integ01.obj
ButtonW.lib(ButtonW.obj) : error LNK2005: _TPL_OA_BUTTONW_DMT already defined in integ01.obj
LINK : fatal error LNK1104: cannot open file 'D:\masm32\ObjAsm\Code\Objects\Lib\32W\Primer.lib'
ButtonW is an ANSI_STRING  object(everything is ANSI) , but perhaps is other thing.

Biterider

  • Moderator
  • Member
  • *****
  • Posts: 437
  • ObjAsm32 + ObjAsm64 = ObjAsm
    • ObjAsm
Re: Fusion libraries are working?
« Reply #1 on: November 23, 2019, 07:45:12 AM »
Hi HSE
It is hard to say, but I think that the problem comes from a double inclusion of a file somewhere.
If you want to share your sources, I can take a look into it.


Biterider

HSE

  • Member
  • *****
  • Posts: 1188
  • <AMD>< 7-32>
Re: Fusion libraries are working?
« Reply #2 on: November 23, 2019, 08:34:32 AM »
If there is no know problem, for sure I making something wrong.

Anyway I will see what happen converting to libraries some tests I have maked before.

Thanks Biterider  :thumbsup:

HSE

  • Member
  • *****
  • Posts: 1188
  • <AMD>< 7-32>
Re: Fusion libraries are working?
« Reply #3 on: November 23, 2019, 10:11:02 AM »
Well, test fail   :sad:.

Switch for Load or Make in aof2.asm line 42. nmake for libraries.

Biterider

  • Moderator
  • Member
  • *****
  • Posts: 437
  • ObjAsm32 + ObjAsm64 = ObjAsm
    • ObjAsm
Re: Fusion libraries are working?
« Reply #4 on: November 23, 2019, 08:26:32 PM »
Hi HSE
The aof2 is really cool stuff  :thumbsup:
I found a solution for user object compilation. I created some files to compile your objects (Pixelmap2 and Graphic1).

I must admit, that it is not very user friendly to compile user objects outside the OA given paths. I'll take note of this for the next release.
Btw, I noticed some compilation issues in 64 bit mode, mostly related to unmatched variable sizes. I'll release a quick fix in the next days.

Now that i fixed this, I see some warnings coming from SmplMath like "WARNING: code not thread save: line 410"... You have to check this.

Attached are the 4 new files. Put them in the aof2 folder. Adjust the paths in the files according to your system and execute MakeMyObjects.cmd.
Finally enable the loading of the precompiled objects in oaf2.asm.

Good luck!

Biterider

HSE

  • Member
  • *****
  • Posts: 1188
  • <AMD>< 7-32>
Re: Fusion libraries are working?
« Reply #5 on: November 24, 2019, 02:40:45 AM »
Hi Biterider!

The aof2 is really cool stuff  :thumbsup:
:biggrin: is 32bit code only pasted, but updating to dual framework at least is a good opportunity to put some order.

I found a solution for user object compilation. I created some files to compile your objects (Pixelmap2 and Graphic1).
Thanks. They are working well  :thumbsup:

Now that i fixed this, I see some warnings coming from SmplMath like "WARNING: code not thread save: line 410"... You have to check this.
Some SmplMath calculations are used only for development, if they become permanent then I make them MT safe.

HSE