Author Topic: I am getting wiser ?  (Read 603 times)

hutch--

  • Administrator
  • Member
  • ******
  • Posts: 9988
  • Mnemonic Driven API Grinder
    • The MASM32 SDK
I am getting wiser ?
« on: March 14, 2022, 08:48:42 PM »
I have 1 box set up as an Apache server and while it worked OK most of the time, the assigned IP kept changing. After p*ssing around with the Windows technique of setting an IP manually which just would not work,

I left it to automatic DHCP and went to the router that with a little exploring, had the option to reserve an IP to a particular MAC address. BINGO, it all worked correctly and I can reliably access the server from any machine.

The Microsoft reference data would have to be labelled as "obscure" = does not work etc ....
hutch at movsd dot com
http://www.masm32.com    :biggrin:  :skrewy:

Vortex

  • Member
  • *****
  • Posts: 2716
Re: I am getting wiser ?
« Reply #1 on: March 15, 2022, 06:11:01 AM »
Hi Hutch,

Quote
the assigned IP kept changing.

This is not usual. What's the IP lease time in the settings of the DHCP server?

hutch--

  • Administrator
  • Member
  • ******
  • Posts: 9988
  • Mnemonic Driven API Grinder
    • The MASM32 SDK
Re: I am getting wiser ?
« Reply #2 on: March 15, 2022, 09:20:36 AM »
Without digging it up, I think its 24 hours but setting the IP in the router solved the problem and funny enough, when I changed the browser link in one edition of Slimjet, the Google sync fixed it in all of the browsers. I don't think there is a technique to set up a domain name server on a LAN of Win10 machines and I don't want to use an external providor.
hutch at movsd dot com
http://www.masm32.com    :biggrin:  :skrewy: