Masm32 SDK description, downloads and other helpful links
Message to All Guests
NB: Posting URL's See here: Posted URL Change

Main Menu

batch file is compiling a previous version

Started by shankle, August 03, 2014, 06:57:42 AM

Previous topic - Next topic


The problem with the code below is not what happened on line 552.
That is fixed, but it is pulling in a previous version of whspellm64
where the offending line at 552 has not been fixed. I have searched the
computer and deleted any duplicate copies of whspellm64 thinking that
might be the problem but it did not solve anything.
I am using Windows 7 pro 64-bit and Notepad++(v6.6.7)
I had this problem once before but can't remember how I solved it....
Thanks for any suggestions.
  Microsoft Windows [version 6.1.7601]
  J:\>cd \codejps
  J:\codejps>Set include= J:\codejps
  J:\codejps>Set Path=J:\codejps
  J:\codejps>GoAsm /x64/b/c whspwllm64.asm
  GoAsm.exe Version
  Line 552 of assembler source file <whspellm64.asm>:-
  Only 32-bit or 64-bit register allowed as index register:-
  addr ax,addr tmsg1,MB_YESNO
  OBJ file not made
  J:\codejps>GoLink /unused whspellm64.obj
  GoLink.exe Version
  Could not open an input file <whspellm64.obj>
  Output file not made
Batch file 
  Set INCLUDE= J:\codejps
  Set PATH=J:\codejps
  GoAsm /x64/b/c whspellm64.asm
  GoLink /unused whspellm64.obj



you could probably write the batch file to rename or copy the source file to something like "temptemp.asm"
build it - then rename it back, after deleting any pre-existing exe



thanks guys for responding.
Problem solved.
Stupid error as usual.