Author Topic: Windows 8 install  (Read 11701 times)

sinsi

  • Guest
Windows 8 install
« on: December 18, 2012, 08:11:37 PM »
All was going well, then message boxes (maybe 10 or so?):

inc2l.exe - Ordinal Not Found
The ordinal 200 could not be located in the dynamic link library
C:\Windows\AppPatch\AcGeneral.DLL.

or AcLayers.DLL.

The install went to the end and indicated success, but I think a few libraries weren't built.

hutch--

  • Administrator
  • Member
  • ******
  • Posts: 8368
  • Mnemonic Driven API Grinder
    • The MASM32 SDK
Re: Windows 8 install
« Reply #1 on: December 18, 2012, 09:20:51 PM »
sinsi,

Try something unusual, if you have a much later version of ML.EXE and LINK.EXE, place them in the BIN directory then run the batch file. There should not be anything in INC2L.EXE that triggers this problem but it repeatedly calls ML.EXE and LINK.EXE.
hutch at movsd dot com
http://www.masm32.com    :biggrin:  :skrewy:

dedndave

  • Member
  • *****
  • Posts: 8829
  • Still using Abacus 2.0
    • DednDave
Re: Windows 8 install
« Reply #2 on: December 18, 2012, 09:40:39 PM »
build it on a different machine and copy it over there   :t

i seem to recall this error on the old forum - something to do with DEP

sinsi

  • Guest
Re: Windows 8 install
« Reply #3 on: December 19, 2012, 06:44:02 PM »
OK, here are the errors, for each one I get two message boxes, one for AcGeneral.dll then one for AcLayers.dll
Quote
Creating library winspool.lib and object winspool.exp
Creating library winsta.lib and object winsta.exp
Creating library winstrm.lib and object winstrm.exp
Creating library wintrust.lib and object wintrust.exp
Creating library wldap32.lib and object wldap32.exp
Creating library wmilib.lib and object wmilib.exp
Creating library wmip.lib and object wmip.exp
Creating library wmvcore.lib and object wmvcore.exp
Creating library wow32.lib and object wow32.exp
Creating library ws2_32.lib and object ws2_32.exp
Creating library wshisotp.lib and object wshisotp.exp
Creating library wsnmp32.lib and object wsnmp32.exp
Creating library wsock32.lib and object wsock32.exp
Creating library wtsapi32.lib and object wtsapi32.exp
Creating library xactsrv.lib and object xactsrv.exp
Creating library xaswitch.lib and object xaswitch.exp
All others worked OK, weird...

Looking at the lib directory, they seem to have been built properly
Quote
19/12/2012  05:49 PM           137,710 winspool.lib
19/12/2012  05:49 PM            73,132 winsta.lib
19/12/2012  05:50 PM             5,878 winstrm.lib
19/12/2012  05:51 PM            87,032 wintrust.lib
19/12/2012  05:51 PM           126,224 wldap32.lib
19/12/2012  05:51 PM             3,488 wmilib.lib
19/12/2012  05:52 PM            32,836 wmip.lib
19/12/2012  05:52 PM            10,584 wmvcore.lib
19/12/2012  05:52 PM            20,604 wow32.lib
19/12/2012  05:52 PM            80,298 ws2_32.lib
19/12/2012  05:53 PM             7,074 wshisotp.lib
19/12/2012  05:53 PM            33,840 wsnmp32.lib
19/12/2012  05:53 PM            50,628 wsock32.lib
19/12/2012  05:53 PM            26,568 wtsapi32.lib
19/12/2012  05:53 PM            81,860 xactsrv.lib
19/12/2012  05:54 PM             6,322 xaswitch.lib

I did run the makelibs.bat file on the first install with no errors, is that the batch file you are talking about?

Vortex

  • Member
  • *****
  • Posts: 2560
Re: Windows 8 install
« Reply #4 on: December 20, 2012, 05:34:21 AM »
Hi Sinsi,

I could not find any copy of AcGeneral.dll on my Windows XP Sp3 installation.

The other one, aclayers.dll is found in :

Code: [Select]
C:\WINDOWS\AppPatch
C:\WINDOWS\system32\dllcache