Masm32 SDK description, downloads and other helpful links
Message to All Guests

Main Menu

Windows 7 Visua lStudio 2008 anomolies

Started by KeepingRealBusy, August 22, 2012, 09:58:53 AM

Previous topic - Next topic


Well, I have several new problems, and a work-around. If I set an INT 3 in the code and assemble, then try to execute, when the INT 3 is hit, Windows sees the error and "is searching for the problem", this search goes on for 10's of minutes. This only seems to occur after an assemble, when I started the system today, I immediately tried to execute the program and Windows immediately asked if I wanted to Debug (Why Oh Why did they interject this dialog into the process anyway??). If you try to wait it out (I waited 20 minutes), you will still be waiting. I tried to start task manager, but moving the cursor to the bottom of the screen to enable the auto un-hide of the Task bar takes about 5 minutes to un-hide, then the right click and start Task Manager takes about 10 more minutes, and everything seems to be in slow-mo. My workaround is to immediately hit Cancel to the initial Windows popup, then kill the CMD Window (it is hung), then start a new CMD Window and then start the executable again. I immediately get the chance to Debug without the huge wait.

The second problem I now see is that I can set a breakpoint, and then step through the code (using VS) with F11 or F10. If I try to move the cursor back to repeat a piece of failing code, then my F11 or F01 is taken as if it were an F5 and I immediately jump to the breakpoint. I have to use the Debug menu and manually say step into or step over, I cannot use the function keys (yes this is a laptop and I have to use the Fn key as well as the F11 key).

My final problem is that my editor of choice (PFE - last release was 1999 and I have been using it ever since) seems to partially run. For some reason I cannot get it to accept any option changes and remember them across executions. The program was supposed to set up registery entries to remember this, but for some reason this is not working.  I will have to get (and learn) another editor. Bah! Another problem is that many times I loose the screen cursor. The keyboard works, but you have no way to determine where the new data is placed. Another cursor problem is when you move the mouse and click on a new location, the screen cursor will be placed there, but if you type, the data is still placed in the old location!!! I guess I'll have to see what the MASM32 Editor is all about.

I am about ready to buy the wife a brand new machine, and reclaim my old XP machine, but I do not think she would be anymore happy with Windows 7 than I am.

Many of my favorite old tools also do not run on Windows 7, double Bah!

Sorry for the rant. I feel much better now.



Yes, on Win7 the "Windows is searching for a solution" is really a nuisance. I have set Olly as JIT debugger, and occasionally I can see that dialog, too :bgrin:

But normally, I just insert an int 3 somewhere in my code, hit F6, and my editor assembles, links, and starts Olly with the executable plus args in the commandline. No silly dialog, and Olly jumps straight to the int 3.

Perhaps VS gives you an option to launch Olly instead of the executable; otherwise, use a batch file...



Thank you for the reply, but just having to learn a new editor as well as a new OS is enough for now, I do not want to also learn a new debugger (I have used VS 2008 for 4 years now - don't really want to change unless I have to). But this raises a question. Why is VS acting differently than it was under Windows XP? My guess is that when I installed, I saw a message that it was installing the 64 bit version of VS, XP had the 32 bit version. Should there that much difference between the versions?